Aller au contenu


Photo
- - - - -

avis et validation pour un montage


12 réponses à ce sujet

#1 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté 11 septembre 2018 - 07:35

Bonjour,

Je suis nouveau sur le forum et souhaiterais me lancer dans ce projet . Mon objectif est d'avoir un moteur qui tourne pour développer le pousse-seringue. Comme je débute, pour l'instant c'est un projet test qui se veut simple pour valider que ça peut fonctionner.

J'aurais de ce fait besoin de votre validation svp.

Après renseignements pris sachant que je débute, j'en arrive à proposer le montage suivant qui devrait correspondre à mes besoins : 1 pilote TB6600+1 Carte UNO+1 moteur NEMA17+1 alimentation12V400W:

 

Toutes mes recherches m'ont conduit à proposer les étapes suivantes :

>>Etape 1 :
Régler le microstepper TB6600 sur 2,8A (est-ce ok ?) et « Microstep » sur 16.

>>Etape 2, câblage :
     - avec câble breadboards :
ENA-(ENA), DIR-(DIR) & PULL-(PULL) --> relié à l'un des ports GND de la carte Arduino Uno
ENA+(+5V) --> relié à DIGITAL PORT 8 de la carte Arduino Uno
DIR+(+5V) --> relié à DIGITAL PORT 7 de la carte Arduino Uno
PULL+(+5V)-- > relié à DIGITAL PORT 4 de la carte Arduino Uno
B- --> relié à câble bleu du moteur Nema
B+ --> relié à câble rouge du moteur Nema
A- --> relié à câble vert du moteur Nema
A+ --> relié à câble noir du moteur Nema
  -avec câble fournis avec l'alim type 2.5 mm² :
GDN TB6600 > relié à V- de l'alimentation 12V400W
VCC --> V+ de l'alimentation 12V400W

>>Etape 3 Suite logicielle :
  - 1/ télécharger GRBL 1.1 puis téléverser dans Arduino
  - 2/ installer UGS version classic
>>>>  je voudrais savoir si la gestion des pins comme branchés ci-dessus sera possible sans modification nécessaire des programmes ?
 

Tout ceci vous semble-t-il correct ?

 

Grand merci d'avance pour votre retour.
Bonne journée.



#2 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 7 190 messages
  • Gender:Male
  • Location:Cholet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 11 septembre 2018 - 01:24

étape 1,  
ça dépend de ton moteur pour l'ampérage max. 
Si ton moteur pas à pas est le moteur pas à pas nema 17 de la boutique => ok =)

 

 

étape 2 ,

ça dépend de ton moteur et si c'est bien un bipolaire de plus certains moteurs ne respectent pas le même code couleur.
Si ton moteur pas à pas est le moteur pas à pas nema 17 de la boutique => Ok, 
Sinon, si ton moteur a bien juste 4 fils, il faut que tu vérifies avec voltmètre en mode testeur si ça sonne quand tu touche le bleu et le rouge =) idem pour le vert et le noir . 

 

étape 3 , 
Jamais utilisé ça donc je ne sais pas. 
Par contre on a un tuto pour faire tourner ton moteur pas à pas avec une arduino en utilisant les pins que tu as choisis : 
test du moteur nema 17 par ashira


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !

 

Les réalisations de Mike118  

 

 

 


#3 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté 11 septembre 2018 - 05:31

Bonsoir,

Pour le moteur, j'en ai un petit qui traîne et que je compte essayer pour valider le montage. J'ai joint les spécifications au message si vous pouviez jeter un oeil.

Concernant le tuto, j'ai regardé :

- je n'ai pas trouvé de tuto (la méthode pour faire tourner le moteur) en tant que tel (peut-être suis-je passé à côté).

- par contre je suis intéressé pour connaître le schéma de branchement avec le potentiomètre, ça pourrait m'intéresser.

Merci d'avance pour votre retour,

Bonne soirée.

Image(s) jointe(s)

  • spec_moteur.jpg


#4 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté 11 septembre 2018 - 08:46

Je complète mon message. Je serais intéressé de savoir si mes branchements avec mon moteur pourraient convenir avec le matériel suivant :
-http://www.robot-mak...nes/20-uno.html
- http://www.robot-mak...140-tb6600.html
- http://www.robot-mak...-male-male.html

L'alimentation 12v400W je l'ai déjà.

Merci pour vos retours.

#5 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 7 190 messages
  • Gender:Male
  • Location:Cholet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 11 septembre 2018 - 11:51

Je lis " 1.6A / phase " donc du coup il faut régler à la baisse le courant. 

 

Pour le tuto, il y a le code sur le lien du test du TB6560 j'aurais du te donner ce lien en premier. 


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !

 

Les réalisations de Mike118  

 

 

 


#6 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté 12 septembre 2018 - 06:40

Bonjour,

 

J'ai bien consulté les tutos mais partir sur cette option me demanderait de revoir tout mon projet. Je débute de zéro et pour l'instant j'ai mis pas mal de temps à trouver une solution qui devrait tenir la route (je croise les doigts) avec le matériel que je proposais.

 

Du coup, est-ce que je peux réaliser mes branchements (sont-ils bons ?) avec le matériel que je propose dans les posts #3 et #4 (pour la partie logicielle GRBL/UGS je pourrai avoir des conseils mais a priori ça devrait fonctionner) ?

 

Merci d'avance.



#7 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 7 190 messages
  • Gender:Male
  • Location:Cholet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 12 septembre 2018 - 07:57

En fait on a plus le matériel cité en stock ... il nous restait bien un TB6600 mais il n'est plus disponible.

Ce qu'on a en stock d'équivalent c'est un TB6560 et cet arduino uno fournie avec son câble usb et qui ne nécessite pas de driver supplémentaire. 


En tout cas je confirme juste que c'est bien que : 

 

 

B- --> relié à câble bleu du moteur Nema
B+ --> relié à câble rouge du moteur Nema
A- --> relié à câble vert du moteur Nema
A+ --> relié à câble noir du moteur Nema
  -avec câble fournis avec l'alim type 2.5 mm² :
GDN TB6600 > relié à V- de l'alimentation 12V400W
VCC --> V+ de l'alimentation 12V400W

 

 

C'est ok par rapport à la doc du moteur que tu as fournis. 


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !

 

Les réalisations de Mike118  

 

 

 


#8 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté 13 septembre 2018 - 07:48

Bonjour,

 

Je pourrai être bien intéressé de ce fait par ce matériel :

- http://www.robot-mak...board-mini.html

- http://www.robot-maker.com/shop/cartes-programmables/193-clone-arduino-uno-16u2.html ( si 100 % sans problème à l'installation ;) )

- http://www.robot-mak...-tb6560-3a.html

- http://www.robot-mak...fils&results=35

 

Pourriez-vous toutefois me valider les branchements du moteur que j'ai déjà sur ce TB6560 et vers la carte UNO (de mon côté j'ai trouvé ce deux tutos : 1 ; 2) ?

 

Juste une petite question, quelle différence entre entre le TB6560 et TB6600 ?

 

Bonne journée.



#9 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 7 190 messages
  • Gender:Male
  • Location:Cholet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 13 septembre 2018 - 10:16

La différence entre le TB6560 et le TB6600 réside dans le boîtier et les borniers. 

 

Sinon pour le matériel c'est bon idem pour les branchements, qui sont identiques à ceux du TB6600. 
 


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !

 

Les réalisations de Mike118  

 

 

 


#10 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté 13 septembre 2018 - 10:22

d'accord

 

juste une petite précisions svp pour être sûr car ce n'est pas tout à fait la même terminologie, du coup je propose ceci

GND 12V noir

V+ 12V rouge

CLK-, CW-, EN- pin GND arduino uno

CLK+ pin 7 ouo 4 ? arduino uno

EN+ pin 8 arduino uno

CW+ pin 7 ou 4 ? arduino uno

B- --> relié à câble bleu du moteur Nema
B+ --> relié à câble rouge du moteur Nema
A- --> relié à câble vert du moteur Nema
A+ --> relié à câble noir du moteur Nema

 

par contre, je n’ai aucune idée pour la configuration du pilote (j’ai trouvé un tuto ici) pour mon montage ?

 

merci

bonne journée



#11 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 7 190 messages
  • Gender:Male
  • Location:Cholet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 13 septembre 2018 - 01:42

Sur le principe tu peux brancher  CLK+ EN+ et CW+ sur n'importe quel pin de l'arduino, il faudra juste que le programme soit mis pour correspondre au câblage. 

Ou bien inversement, il faut faire correspondre le câblage au programme... Si c'est ce que tu souhaites poste ici le code que tu compte mettre dans l'arduino et en le lisant je pourrais te confirmer les pins CLK+ EN+ et CW+ . 

 

Quoi qu'il en soit tu ne risque absolument rien en inversant juste ces deux pins ... 

 

CLK contrôle l'avance pas à pas du moteur, CW indique le sens.

Grossièrement, CW est un signal "fixe" tant que le moteur ne change pas de sens, et CLK sera un signal en forme de pulses consécutives plus ou moins rapide en fonction de la vitesse demandé au moteur tant que le moteur bouge. 

Si jamais tu inverses les deux le moteur ne bougera juste pas, ça serait comme si tu demandais au moteur de changer de sens plein de fois mais sans lui demander d'avancer ...  


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !

 

Les réalisations de Mike118  

 

 

 


#12 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté 13 septembre 2018 - 06:05

Ok, je note du coup que c'est ok pour les branchements (hormis pins 7/4 à valider).

Pour la partie logicielle comme je ne maîtrise pas Arduino je comptais contourner le problème en passant par GRBL et utiliser du GCode pour animer le moteur (G92 F100 Z10 par exemple)

Je suis preneur par contre d'infos sur les programme que je devrais faire via l'IDE Arduino sans GRBL et qui correspond au montage (des tutos ou même un exemple de programme)

Pour ce qui est de l'utilisation de la j'y connais rien mais j'ai déjà mis des tutos de côté pour comment lancer un programme via l'IDE Arduino.

Merci pour vos conseils sur cette partie logicielle.

#13 infosmaker

infosmaker

    Nouveau membre

  • Membres
  • 20 messages

Posté aujourd'hui, 14:51

Bonjour,

 

Pour l'instant je vais au final partir sur Arduino, et là j'attends de pouvoir faire le montage.

 

Bon après-midi.





Répondre à ce sujet



  


0 utilisateur(s) li(sen)t ce sujet

0 members, 0 guests, 0 anonymous users