Aller au contenu


Photo
- - - - -

Le projet de clément


14 réponses à ce sujet

#1 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 09 février 2014 - 10:07

Le but de ce projet est de me faire découvrir l’univers de la robotique. Ce projet sera donc assez simple mais avec des idées d’évolution.
Je précise juste que ce projet n’est pas dans le cadre scolaire.

L’objectif est de faire une voiture « autonome », enfin juste qu’elle ne se prenne pas les murs !!

La différence avec le même type de projet qu’on trouve sur le net c’est la direction, en effet les roues tournent réellement contrairement aux projets ou l’on fait tourner un coté du robot pour tourner (pas facile à expliquer !)

Le matériel :
- Une arduino Uno
- Un capteur ultrason
- Un châssis de voiture télécommandé
- Une carte de gestion moteur L298N

DSCN2496.JPG
DSCN2497.JPG

Donc pour le moment il faut que lorsque la voiture arrive à 60cm du mur elle tourne (La voiture est prévue pour tourner en extérieur)

Tout d’abord il me faut changer le servo moteur de la direction, en effet il est assez spécial, il comporte 6 fils :

Noir : alimentation moteur
Bleu : antiparasitage
Blanc : milieu du potentiomètre
Vert : Borne potentiomètre
Jaune : Borne potentiomètre

J’ai donc commandé un servomoteur classique à 3 fils

Concernant les évolutions possibles, je pense surtout à une commande IR avant de prendre un dispositif de plus longue portée ou encore un servo supplémentaire pour pouvoir adapté le capteur dessus ainsi le robot fera un choix en fonction de la place qu’il y a sur les cotés

Pour le moment j’attends le matériel que j’ai commandé !

& bien sur vous pouvez donner votre avis !!

Bonne journée

#2 transistance

transistance

    Membre passionné

  • Membres
  • PipPipPip
  • 409 messages

Posté 09 février 2014 - 02:09

Bonjour,

La différence avec le même type de projet qu’on trouve sur le net c’est la direction, en effet les roues tournent réellement contrairement aux projets ou l’on fait tourner un coté du robot pour tourner (pas facile à expliquer !)


si si, je pense que tout le monde comprendra ne t'en fait pas ;)
Par contre détrompe toi, même si cette approche est plus rare, on trouve tout de même des projets de la sorte sur la toile. Moi même j'en ai bidouillé un dans ma jeunesse.

Tout d’abord il me faut changer le servo moteur de la direction, en effet il est assez spécial, il comporte 6 fils :

Noir : alimentation moteur
Bleu : antiparasitage
Blanc : milieu du potentiomètre
Vert : Borne potentiomètre
Jaune : Borne potentiomètre


En fait c'est parceque l'électronique du servo de ta voiture RC (sans doute une ancienne NIKKO) est déporté sur la platine de réception. C'est, de mémoire, le CI made in nikko qui contient tout (réception/démodulation + gestion servo).
Donc t'as bien fait d'investir dans un servo classique.

Bonne continuation!

N'oubliez jamais que "Ban Ki-moon n'attrape pas mousse"


#3 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 17 février 2014 - 07:42

merci transistance,

Je pensais que l'on recevait un mail lorsqu'une réponse été déposé comme souvent sur les forums, du coup j'ai cru qu'il n'y avait pas eu de réponse ...

J'ai reçu la carte arduino samedi et me suis amusé ce week end a programmer quelques truc et je dois avoué que je suis assez impressionné de tous ce que l'on peu faire !!!

Enfin j'ai essayé d'assembler ma voiture mais la je ne suis pas trop satisfait, le chassis n'est pas super super le moteur est trop puissant et gourmand. Je pense donc m'orienter vers l'achat d'un chassis avec motoreducteur intégrer car je n'ai pas envie de me poser trop de problème au niveau mécanique !

Si certain on des adresses, j'ai fais quelques recherches et je tombe toujours sur les mêmes chassis : roverà chenille, les modèles à 4 roues et ceux a 3 roues qui sont dans des prix raisonnable après on dépasse les 100 voir 200€ O_o

#4 transistance

transistance

    Membre passionné

  • Membres
  • PipPipPip
  • 409 messages

Posté 17 février 2014 - 09:25

Si certain on des adresses, j'ai fais quelques recherches et je tombe toujours sur les mêmes chassis : roverà chenille, les modèles à 4 roues et ceux a 3 roues qui sont dans des prix raisonnable après on dépasse les 100 voir 200€ O_o


Oui c'est très cher pour des trucs pas forcément à la hauteur... C'est là où le fait maison a ses avantages.

Qu'entends tu par "trop puissant" ? tu as fait quoi avec pour déterminer ça ?

N'oubliez jamais que "Ban Ki-moon n'attrape pas mousse"


#5 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 18 février 2014 - 02:55

Le moteur consomme pas mal (ampermètre) de plus la voiture est bien pour rouler assez vite en extérieur mais pour faire un "robot" c'est pas super !

Tu prends quoi comme base pour faire un robot, tu pars d'une plaque de plexi ?

#6 transistance

transistance

    Membre passionné

  • Membres
  • PipPipPip
  • 409 messages

Posté 18 février 2014 - 05:51

Tu veux dire que tu met ton moteur, ta batterie et ton ampéremètre en série ?

Tu prends quoi comme base pour faire un robot, tu pars d'une plaque de plexi ?

En réalité tout dépend du poids et des dimensions du robot. Pour un robot petit ou moyen du plexi c'est bien.

N'oubliez jamais que "Ban Ki-moon n'attrape pas mousse"


#7 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 18 février 2014 - 07:32

Oui c'est cela, mise à part que j'ai utilisé une alim et mis un ampermètre en série.

#8 transistance

transistance

    Membre passionné

  • Membres
  • PipPipPip
  • 409 messages

Posté 18 février 2014 - 09:13

Oui c'est cela, mise à part que j'ai utilisé une alim et mis un ampermètre en série.


C'est pour ça que tu imagine ton moteur trop puissant et trop gourmand en énergie puisque tu as fait une mesure à pleine puissance. En robotique on commande rarement les moteurs en tout ou rien mais avec un signal PWM (Pulse Width Modulation) ou MLI en français pour Modulation en largeur d'impulsion. En gros ça permet de faire varier la vitesse en hachant la tension d'alim. La vitesse est proportionnelle au rapport cyclique appliqué.

N'oubliez jamais que "Ban Ki-moon n'attrape pas mousse"


#9 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 26 février 2014 - 10:31

Merci transistance,

Je connait aussi le PWM, mais la voiture n'étant pas assez maniable j'ai fini par acheter des chenilles tamiya ainsi que les moto-réducteur histoire de me faire un truc assez sympa. Le but est de découvrir un peu tous ce que l'on peu faire ...


Je ne sais pas encore précisément ce que je vais commencer à faire, je viendrais présenter mon "cahier des charges" prochainement !!

#10 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 06 mars 2014 - 11:01

J'ai reçu mes chenilles tamiya ainsi que le bloc motoréducteur !

DSCN2517.JPG

J'ai été surpris de l'avoir aussi vite étant donné que j'avais lu qu'il fallait 2 à 3 semaines lorsqu'on commande chez robotshop alors que la, ça a mis 10 jours (7 jours ouvré)

Je vais me lancé dans la fabrication du châssis !

#11 Newbies

Newbies

    Membre passionné

  • Membres
  • PipPipPip
  • 487 messages
  • Gender:Male
  • Location:Paris
  • Interests:Programmation et robotique

Posté 22 mars 2014 - 12:08

Tu parle de contrôler tes moteurs avec un L298N. Moi j'utilise cette même gearbox et ces mêmes chenilles sur mon robot et j'ai opté pour un L293D qui est beaucoup plus facile à utilisé et moins cher et ça marche nickel ( Il chauffe juste un peut ).

A toi de voir donc ( l'option L293D te permettrais juste de te familiariser avec la soudure toussatoussa ) :)

#12 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 04 mai 2014 - 09:32

Merci pour ton conseil mais j'ai eu l'occasion d'avoir des L298N ...

Le robot sera donc piloter avec les émmeteur récepteur 433mhz, puis le pont en H L298N pilotera les 2 moteurs

J'ai reçu toute les pièces et j'ai commencé à faire les tests par contre je rencontre un problème, en effet lorsque je fais les branchements comme sur le schéma si dessous il n'y a que le premier ordre qui fonctionne et pour les suivants c'est casi impossible, il faut que je colle la télécommande au récepteur et que j'appuis beaucoup de fois sur le bouton et une fois sur 20 ça marche (par exemple j'appuis sur la touche mettre en avant les moteurs tourne et lorsque j'appuis sur la touche "recule" impossible pourtant si je redémarre la carte arduino et que j'appuis sur "recule" il recule mais toujours impossible d'aller en avant, à gauche ou a droite)

J'ai donc débrancher le pont en H et mis des LED pour chaque ordre (avant, arrière, gauche, droite) et là pas de problème ^^ le soucis viendrait donc du pont en H, je l'ai donc testé séparément en m'étant un programme qui fait tourner les moteurs en avant, en arrière, à gauche, à droite pendant 20 secondes dans chaque sens et les ordres l'un a la suite des autres et là pas de soucis ... le problème viendrait donc de l'association de ces deux montages ?

J'ai volontairement pas relier les entrées du L298N (elles sont relié sur les pins 4,5,6,7) et le recepteur sur la pin 2

Image IPB


Merci pour votre aide là je n'ai plus de solution ^^

#13 ChristianR

ChristianR

    Membre passionné

  • Membres
  • PipPipPip
  • 474 messages
  • Gender:Male
  • Location:Isère (38)
  • Interests:Arduino, programmation, électronique...

Posté 04 mai 2014 - 11:47

Sur ton schéma l'Arduino ne fait rien !

La sortie du 433MhZ doit aller sur une entrée Arduino (1 pin), qui pilote par d'autre pins séparées configurées en sortie les 2 moteurs.
Christian

#14 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 04 mai 2014 - 12:38

Oui, c'est pour cela que j'avais marqué "J'ai volontairement pas relier les entrées du L298N (elles sont relié sur les pins 4,5,6,7) et le récepteur sur la pin 2 "

Je ne voulais pas sur-charger le schéma ^^^

Je vous joint aussi je programme arduino :

#include <RCSwitch.h>

RCSwitch mySwitch = RCSwitch();

void setup() {

Serial.begin(9600);
mySwitch.enableReceive(0); // Receiver on inerrupt 0 => that is pin #2

pinMode(4,OUTPUT);
pinMode(5,OUTPUT);
pinMode(6,OUTPUT);
pinMode(7,OUTPUT);

}

void loop() {

if (mySwitch.available()) {

int value = mySwitch.getReceivedValue();


if (value == 4216085 ) {


digitalWrite(4,LOW);
digitalWrite(5,HIGH);

digitalWrite(6,LOW);
digitalWrite(7,HIGH);

}

if (value == 21780 ) {

digitalWrite(4,LOW);
digitalWrite(5,HIGH);

digitalWrite(6,HIGH);
digitalWrite(7,LOW);

}

if (value == 4210773 ) {

digitalWrite(4,HIGH);
digitalWrite(5,LOW);

digitalWrite(6,LOW);
digitalWrite(7,HIGH);

}

if (value == 16468 ) {


digitalWrite(4,HIGH);
digitalWrite(5,LOW);

digitalWrite(6,HIGH);
digitalWrite(7,LOW);

}

mySwitch.resetAvailable();
}

}


Si vous voyez une solution à ce problème ...

#15 #clem

#clem

    Nouveau membre

  • Membres
  • 17 messages

Posté 15 mai 2014 - 06:49

Problème résolu !

Il y avait un problème de code ...

La librairie RCswitch ne doit pas être adapter à cette utilsation, mieux vaut utiliser la librairie VirtualWire.h

Bonne soirée



Répondre à ce sujet



  


0 utilisateur(s) li(sen)t ce sujet

0 members, 0 guests, 0 anonymous users