Aller au contenu


Photo
- - - - -

Commande Moteur


37 réponses à ce sujet

#21 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 09 juin 2008 - 10:20

Je sent bien la diode de roue libre qui fait plus son travail.

Et une 1N4007 , s'est pas 1 A max?

Comme s'est un moteur qui dois consommer pas mal, créé une isolation galvanique un relais s'est une solution. ( tu auras plus le problème de diode de roue libre a 1A )

#22 Jan

Jan

    Webmaster

  • Membres
  • PipPipPipPipPip
  • 4 747 messages
  • Gender:Male
  • Location:Rhône Alpes

Posté 09 juin 2008 - 10:55

Salut

Et une 1N4007 , s'est pas 1 A max?


Oui mais tu dois pouvoir contrer le pic d'intensité du démarrage à ce que dit le datasheet non ?
Par contre oui c'est 1 A max.

Tu fais ton circuit sur quel support ?

#23 victor

victor

    Nouveau membre

  • Membres
  • 23 messages

Posté 11 juin 2008 - 09:51

Bonsoir à tous,

Désolé d'avoir été aussi long mais le travail ... ;-)

Bien j'ai une bonne et une mauvaise nouvelle :
La mauvaise : j'ai deux BUZ11 HS la bonne c'est qu'il m'en reste un :-)

Donc comme Mattheiu la sugérré avec ce troisieme j'ai fait le meme montage mais avec une Led à la place et ca fonctionne tres bien :-)

j'ai ensuite mis une charge plus importante (25W) et ca fonctionne toujours :-)

Je pense que le problème est que le buz11 crame quand j'utilise le moteur, donc voici ce que j'en conclus que :
Le moteur ne devrait pas consommer plus 2A à vide (ce que je ne peux verifer car je n'ai pas d'Ampere-metre avec moi) m'ais c'est donc théoriquement l'équivalent de ma charge de 25W.

Donc je ne vois que la surtension ou l'intensite du demarrage/arret moteur qui flingue le buz11.
Effectivement j'ai fais l'erreur de ne regarder que la tension de la 1N4007 .... qu'elle erreur .... j'apprends :-)

Je reviens des que j'ai assimilé tous cela, d'ailleur connaissez vous quelques chose à lire (site, pdf ou autre) expliquant le fonctionnement/calcul du MOS ?

Merci encore :-)

PS : Matthieu, pour le relais c'est une tres bonne idée, mais voici quelques une de mes "obligations" :
- Je souhaite ensuite faire du PWM sur ce moteur (pour apprendre meme s'il fonctionnera en tout ou rien)
- Utilisation sur batterie donc si ve peux eviter la consommation d'un relais supplemenaire ;-) (je sais j'abuse)
- Ce projet est avant tout didactique la tondeuse est un pretexte :-)

#24 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 11 juin 2008 - 10:46

Les relais , sa consomme un peu plus , mais sa va encore .

Mais si tu veux apprendre a faire quelque chose , tu peux faire un modèle réduit avant .

Je m'explique tenter un robot tondeuse , sa peux être pas mal , mais la première chose que je ferai : un robot de 500 g pour faire la direction.

Pourquoi , pour tondre , on va en ligne droite , il faut trouver un moyen qui reste en ligne droite ( j'ai fait un suiveur de ligne , je peux t'affirmer que mon robot allais bien mieux sur un virage a 90 qu'en ligne droite ... )

S'est a sa que je ferai en premier. ( tu fait un petit robot que tu test sur ta table , tu en auras déjà pour des heures de travail , donc sa seras plus simple au moment ou tu va travailler sur ta tondeuse )

Ensuite , il faut penser a une chose , l'hélice ne dois pas rester bloqué , il faut donc vérifier qui tourne ( 2 solutions un capteur optique , qui calcule la vitesse / un testeur de courant pour savoir si s'est dur ou simple )

Désolé , de te rajouter du boulot , mais vérifier que le moteur n'est pas bloqué , s'est très important, sa t'évite d'avoir des problèmes ... ( le moteur qui claque ... )

#25 victor

victor

    Nouveau membre

  • Membres
  • 23 messages

Posté 12 juin 2008 - 01:27

Bonjour à Tous,

Matthieu, merci encore pour tes réponses et ne soit pas désolé du travail supplémentaire que tu m'inflige, c'est exactement ce genre de conseil que j'attends :-)))

- Je suis d'accord avec toi sur le principe du petit robot j'avais hésité à le faire, cependant ce qui m'interresse c'est d'avantage l'electronique de puissance (et j'ai besoin d'avoir une utilité à mes montages pour trouver la motivation nécessaire avec le peu de temps que j'ai a y consacrer).

- Pour ce qui est d'aller droit je sais que ce ne sera pas le cas. Ce n'est pas génant et pris en compte pour la premiere phase (tonte aléatoire : J'avance jusqu'a obstable, recule pendant quelques seconde, rotation de l'ensemble, et avance de nouveau).

- Pour ce qui est de la puissance consommée par le moteur idem c'est pris en compte, je veux dire que je compte la surveiller (via un AOP sur le Micro) mais en phase 2. En phase 1 il n'y aura qu'une simple protection thermique + protection mécanique/electrique.

- Concernant mon schéma n°1 j'ai deux questions :
Pour calculer la valeur de la résistance de R1 etant donné que le MOS travail en tension que dois-je prendre en compte pour le calcul de celle ci ? la valeur de Ig (Gate to source Forward Leakage) ?

- Toujours sur ce schema n°1, n'y a t il pas un probleme quand le Micro mettra la sortie à 0v (donc à la masse) la Grille du MOS se retrouvera donc elle aussi à la masse et le MOS fume ? il faudrait donc une isolation opto entre le Micro et la Grille du MOS ?

- D'apres ce que j'ai compris plus Vgs est grand (proche de Vds tout en restant eveidement dans les seuils de tolérance) on peut tirer d'avantage d'intensité entre D et S donc voici un montage n°2 et aussi mes questions ;-)

http://www.resolx.com/mediawiki/upload/6/6...age-coupen2.jpg

- Est-ce que ce schema a du sens ?
- Puis-je esperer à terme faire un PWM et sa frequence sera limité aux caracteristiques de T1+Q1 ?

Bernard, Je fais mes essais sur une platine d'essais sauf pour la puissance ou je soude des fils de 0,75 mais lors de mes essais, le moteur etait à vide et je ne devrais pas consommer + de 2A en regime constant. Tu vas me dire que mon cablage est une antenne (Haute impedance) ?

Merci encore :-)

#26 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 12 juin 2008 - 05:06

Ton montage ne fonctionneras pas je crois , il faut un PNP , donc , il te faudras un montage avec un transistor NPN puis PNP , puis ton mos .

Image IPB

Montage de BAC STI électronque

Mais , je suis pas sur pour ta diode , elle me parais trop faible ...

Ps : les valeur , sont fausse ....

#27 victor

victor

    Nouveau membre

  • Membres
  • 23 messages

Posté 12 juin 2008 - 06:42

Ton montage ne fonctionneras pas je crois , il faut un PNP , donc , il te faudras un montage avec un transistor NPN puis PNP , puis ton mos .

Image IPB

Montage de BAC STI électronque

Mais , je suis pas sur pour ta diode , elle me parais trop faible ...

Ps : les valeur , sont fausse ....



Merci Matthieu,

- Je comprends mon erreur, par contre sais tu me dire l'interet d'un driver MOS par rapport à mon montage ou plutot celui que tu as joint ?

- Pour la 1N4007 c'est la prochaine etape ;-) j'essais pour l'instant de mieux cerner le MOS.

Merci
PS : pourquoi mentionnes tu que c'est un montage de BAC STI ? pour me rappeler que j'ai trop séché pendant cette période ;-))) J'aurais pas du secher .... j'aurais pas du .... on comprend toujours trop tard ;-)
D'ailleur je n'aurais pas du sécher les cours de Francais non plus :-))

#28 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 12 juin 2008 - 07:45

En fait , s'est un montage que je me souviens de mon bac STI , ( projet d'électro )

En fait , la différence entre mos et bipolaire , s'est que les bipolaire fonctionne en courant , les mos en tension .

Les bipolaire pour augmenter le béta , tu dois utiliser un darlington que les mos , tu peux les mettre en parallèle( ils s'équilibre , je te dirais pas comment pour pas t'embrouiller ... )

Sinon , s'est pas bien de sécher les cours

#29 victor

victor

    Nouveau membre

  • Membres
  • 23 messages

Posté 16 juin 2008 - 01:44

En fait , s'est un montage que je me souviens de mon bac STI , ( projet d'électro )

En fait , la différence entre mos et bipolaire , s'est que les bipolaire fonctionne en courant , les mos en tension .

Les bipolaire pour augmenter le béta , tu dois utiliser un darlington que les mos , tu peux les mettre en parallèle( ils s'équilibre , je te dirais pas comment pour pas t'embrouiller ... )

Sinon , s'est pas bien de sécher les cours


Bonjour à Tous,

je ne comprends pas l'interet de Q1 ? enfin du montage darlington, si le MOS se commande en tension seulement une faible intensite devrait transiter alors sur la Gate donc ce n'est pas suffisant d'attaquer la base de Q2 ?

Merci et bon apres-midi :-)

#30 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 16 juin 2008 - 05:31

Q2 est passant a +5 V si VB2 = 5V et il est aussi passant a VB2=0 v

Avec Q1 on augmente la tension , si VB1 = 5V VB2=0 >>Q2 Passant
Si VB1=0v Vb2=VCC >> Q2 bloqué .

Le darlinton aurais fonctionné , mais t'aurais eu un rendement très mauvais .

#31 Positron

Positron

    Nouveau membre

  • Membres
  • 48 messages
  • Gender:Male
  • Location:Exoudun
  • Interests:Electronique, informatique, web et robotique

Posté 20 juin 2008 - 09:46

Bonjour à tous,

Je viens de survoler ce topic.
Ah si j'étais plus diponible je vous aurai éguillé sur ce coup là (car j'ai un projet similaire sous le coude).

Donc je ne vois que la surtension ou l'intensite du demarrage/arret moteur qui flingue le buz11.
Cerise sur le gateau j'ai bien une DRL (1N4007) :-)


Groooosse erreur !!!

La diode de roue libre doit être capable de passer le courant max du moteur soit => 20 A !!
Eh oui c'est cher ! En plus il faut une diode rapide.
Il faut bien dimensionner le radiateur de refroidissement malgré un fonctionnement en commutation (on dissipe de l'énergie au momment de la mise en conduction et à l'arrêt de la conduction du transistor).

Pour ce genre d'application un IGBT va très bien également.

Chose importante : isoler la commande => optocoupleur entre "le micro" et la puissance ;
donc en pratique 2 alimentations : une pour la commande (3,3 à 5v) et une de puissance pour les moteurs.

En cas d'incident on coupe la puissance.

Si le moteur de doit pas varier de vitesse on peut envisager un relais (type relais automobile sur support 20A ça existe).

Mais de toute façon il faudra économiser l'énergie (important pour un robot autonome) donc l'électronique est faite pour cela.

Petit rappel : la PWM permet un controle de vitesse (on agit sur la tension moyenne)
Pour controler le courant il faut agir sur la fréquence !

Donc il faut dans la branche du transistor de puissance mesurer ce courant et par retour agir sur une commande tout ou rien de la commande de ce transistor : on peut ainsi controler et régler le courant de démarrage et détecter le blocage du moteur et donc limiter le courant en de blocage .


Voila pour vous aidez un peu.

Olivier
Suivre positron-libre sur Facebook pour voir les nouveaux cours ou tutos

#32 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 20 juin 2008 - 11:44

Groooosse erreur !!!

La diode de roue libre doit être capable de passer le courant max du moteur soit => 20 A !!
Eh oui c'est cher ! En plus il faut une diode rapide.

J'avais raison donc :)

Puis il faut savoir que le transistor consomme quand il passe saturé / bloqué , donc au plus tu le fait commuter vite , au plus il chauffe .

La solution pour pas payer trop cher , s'est un relais avec un pouvoir de coupure de 20 A

#33 Positron

Positron

    Nouveau membre

  • Membres
  • 48 messages
  • Gender:Male
  • Location:Exoudun
  • Interests:Electronique, informatique, web et robotique

Posté 20 juin 2008 - 03:38

En effet,

Mais l'électronique est plus souple dans la gestion des courants (c'est la seule solution).
De toute façon il n'y aurai pas du avoir de problème puisque le BUZ à une diode de roue libre intégrée !!!

Sont refroidisseur doit être trop faible (vérifier le contact themique avec le dissipateur et l'isolement électrique entre dissipateur et transistor) ou alors le moteur prend plus que 20 A.
Il faut penser à mettre un fusible pour protéger le moteur et le transistor.

Bonne continuation

Olivier
Suivre positron-libre sur Facebook pour voir les nouveaux cours ou tutos

#34 victor

victor

    Nouveau membre

  • Membres
  • 23 messages

Posté 22 juin 2008 - 05:26

En effet,

Mais l'électronique est plus souple dans la gestion des courants (c'est la seule solution).
De toute façon il n'y aurai pas du avoir de problème puisque le BUZ à une diode de roue libre intégrée !!!

Sont refroidisseur doit être trop faible (vérifier le contact themique avec le dissipateur et l'isolement électrique entre dissipateur et transistor) ou alors le moteur prend plus que 20 A.
Il faut penser à mettre un fusible pour protéger le moteur et le transistor.

Bonne continuation

Olivier


Bonjour à Tous,

Olivier merci beaucoup pour tes précisions, et oui je pense que tu as raisons j'ai du cramer le BUZ11 à cause de la temperature ...

Donc j'en suis toujours au meme point, je dois controler un moteur (en vitesse, et seulement dans un sens de rotation) avec une consommation max de 20A et peut être plusieurs solutions s'offrent à moi pouvez vous m'aidez à choisir la bonne ? :

(Je veux que la tension de VGS=VDS car c'est comme cela que le MOS me permet de commuter le plus gros courant.)

Donc
1 - Microcontroleur -> Optocoupleur (en existe t'il qui se commande en TTL et qui sortent du 12v) -> Grille du MOS
2- Microcontroleur -> OptoCoupleur -> Driver de MOS -> Grille du MOS
3- Microcontroleur -> OptoCoupleur -> Montage avec 2 transistors comme NPN/PNP -> Grille du MOS

Merci encore et bon Dimanche.

Juste pour vous faire part de l'avancement ;-)

Voici le proto du chassis pour la tondeuse :

http://www.resolx.com/mediawiki/index.php/Chassis_Tondeuse

maintenant il faut que j'avance sur l'électronique ...

#35 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 22 juin 2008 - 05:58

Tout existe regarde : http://www.gotronic.fr/catalog/opto/optofr...=optocoupl1.htm

Attention quand même a if , et n'utilise pas un PWM trop rapide ... ( on place aussi souvent une résistance a la masse puissance et a la base du photo transistor .... )

#36 victor

victor

    Nouveau membre

  • Membres
  • 23 messages

Posté 22 juin 2008 - 07:26

Tout existe regarde : http://www.gotronic.fr/catalog/opto/optofr...=optocoupl1.htm

Attention quand même a if , et n'utilise pas un PWM trop rapide ... ( on place aussi souvent une résistance a la masse puissance et a la base du photo transistor .... )


Comme toujours merci :-)

Donc comme ca ? : http://www.resolx.com/mediawiki/upload/3/3...teur-coupe3.jpg

Comment je calcul le IF ? Je veux dire que par exemple le 4N25 supporte 60ma mais comment est-ce que je calcul la "consommation" du MOS ?

Bonne soirée.

#37 Matthieu

Matthieu

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 604 messages
  • Gender:Male

Posté 22 juin 2008 - 09:04

Ton schéma semble faux

Image IPB
( valeur des résistance fausse , mais R3 négligable devant R2 ( je pense même que R3 sert a rien dans cette configuration ))
If = (vcc-Vdiode) / Rpolarisation , s'est tout simple

Le mos en entrée , il ne consomme pratiquement rien , donc tu dois juste polariser

J'ai GND1 et GND2 Si tu utilise la même batterie , sort les indépendamment , si tu a des problème , prend une petite batterie pour la partie commande ....

#38 victor

victor

    Nouveau membre

  • Membres
  • 23 messages

Posté 24 juin 2008 - 03:02

Bonjour à Tous et merci encore pour vos commentaires :-)

Je vais commander quelques composants pour faire la maquette cependant je me pose la question de mesurer à terme la vitesse de rotation de chacune des roues, j'ai donc besoin de vos lumieres :-)

J'ai vu ce capteur qui pourrait correspondre à mes besoins par exemple : OPB745 (http://www.alldatasheet.com/view.jsp?Searchword=OPB745 ) le probleme va etre pour le trouver ...
Une simple diode avec un recepteur ? le probleme va etre mécanique ... je cherche un capteur qui differencierais par exemple le blanc du noir ce qui me permettrais de peindre quelques rayons en blanc par exemple.

une idée de capteur/compteur que je pourrais utiliser ?


Merci d'avance.



Répondre à ce sujet



  


0 utilisateur(s) li(sen)t ce sujet

0 members, 0 guests, 0 anonymous users