Aller au contenu


Photo
- - - - -

Contrôleur moteur puissant


11 réponses à ce sujet

#1 Leon

Leon

    Membre passionné

  • Membres
  • PipPipPipPipPip
  • 1 289 messages
  • Gender:Male

Posté 10 juillet 2011 - 02:21

Suite à la remarque de julkien sur ce message, je propose un moyen de faire un contrôleur moteur puissant, pas trop compliqué.

Le pont en H est quelque chose de très utilisé, mais on peut faire différemment. Dès qu'on atteint les hautes puissances, on peut essayer la chose suivante:
1) ne mettre qu'un seul Mosfet pour gérer la puissance par PWM
2) gérer l'inversion de marche par un relais 2RT (= 2 contacts repos/travail).

Voici un schéma que j'avais réalisé pour mon premier vrai robot, BOB2.
J'ai refait un truc équivalent plus tard, mais en plus puissant.
schema_puissance.gif

Pour piloter ça, il faut adapter un peu le logiciel:
1) Ne pas faire un asservissement qui engendre trop d'inversions de sens de marche. L'asservissement en position d'une roue sera par exemple tolérant à une petite erreur de position. Du coup, on tolère une "zone morte" pendant laquelle l'asservissement n'est pas opérant.
2) On peut mettre un relais sous-dimensionné. Je m'explique: pas besoin d'utiliser le "pouvoir de coupure" du relais, si on annule le courant avant de changer le relais d'état. On peut faire passer un courant plus important que le "pouvoir de coupure", si on ne coupe pas (ni ne ferme) le relais pendant qu'on y fait passer ce fort courant. Donc on peut très bien réussir à faire un logiciel qui, pour inverser le sens procède ainsi:
- 1 : coupure de la puissance du PWM
- après un certain temps (50ms disons), changement de position du relais
- attendre encore un peu que le relais se stabilise (50ms suffisent amplement)
- remettre la puissance du PWM dans l'autre sens.

Si vous avez des questions, n'hésitez pas!

Leon.

BOB4, mon drone hélicoptère autonome d'intérieur http://heli.bot.free.fr/
BOB3, mon robot autonome d'intérieur avec WiFi + Foxboard Linux http://ze.bot.free.fr/
BOB5, robot bipède simulé, puis tentative de réalisation (fail)


#2 julkien

julkien

    Pilier du forum

  • Membres
  • PipPipPipPipPip
  • 1 029 messages
  • Gender:Male

Posté 10 juillet 2011 - 03:37

ton schéma brille par ça simplicité, même moi je le comprends ! Image IPB

#3 julkien

julkien

    Pilier du forum

  • Membres
  • PipPipPipPipPip
  • 1 029 messages
  • Gender:Male

Posté 17 juillet 2011 - 07:25

ton schéma brille par ça simplicité, même moi je le comprends ! Image IPB


salut

heu visiblement il est pas aussi simple que ça
le composant ULN2803A sert a quoi ? je ne comprends pas vraiment son utilité

#4 Maïck

Maïck

    Membre passionné

  • Membres
  • PipPipPip
  • 390 messages
  • Gender:Male
  • Location:Suisse

Posté 18 juillet 2011 - 09:51

Le ULN2803A sert à driver la bobine du relais, le PIC ne pouvant pas drive assez de courant.

Mise à part ça j'ai de la peine à lui trouver des avantages sur un pont en H... :huh:

Niveau encombrements/coûts le relais est catastrophique... Simplicité ouais tu gagne un composant, mais tu consomme plus.

Et "haute puissance" excuse moi mais je préfère monter un pont en H pour driver 100A que trouver et monter un relais qui les tiennent ! :ph34r:

#5 julkien

julkien

    Pilier du forum

  • Membres
  • PipPipPipPipPip
  • 1 029 messages
  • Gender:Male

Posté 19 juillet 2011 - 05:14

Le ULN2803A sert à driver la bobine du relais, le PIC ne pouvant pas drive assez de courant.

Mise à part ça j'ai de la peine à lui trouver des avantages sur un pont en H... huh.gif

Niveau encombrements/coûts le relais est catastrophique... Simplicité ouais tu gagne un composant, mais tu consomme plus.

Et "haute puissance" excuse moi mais je préfère monter un pont en H pour driver 100A que trouver et monter un relais qui les tiennent ! ph34r.gif

OK et avec un pont en H comme sur mon schema :
on peux varier la vitesse des moteur ?
 

post-1-0-09274900-1411400949.jpg

Image(s) jointe(s)

  • 1311091868.jpg


#6 Leon

Leon

    Membre passionné

  • Membres
  • PipPipPipPipPip
  • 1 289 messages
  • Gender:Male

Posté 19 juillet 2011 - 06:01

Et "haute puissance" excuse moi mais je préfère monter un pont en H pour driver 100A que trouver et monter un relais qui les tiennent ! :ph34r:

Maick, tu connais des ponts en H tout fait qui tiennent les 100A, et qui ne coutent pas trop cher? Si oui, ça m'intéresse beaucoup.

Et pour le relais, relis bien ce que j'écrivais: tu n'est pas obligé de prendre un relais qui a un pouvoir de coupure de 100A.

Leon.

BOB4, mon drone hélicoptère autonome d'intérieur http://heli.bot.free.fr/
BOB3, mon robot autonome d'intérieur avec WiFi + Foxboard Linux http://ze.bot.free.fr/
BOB5, robot bipède simulé, puis tentative de réalisation (fail)


#7 Hexa Emails

Hexa Emails

    Membre passionné

  • Membres
  • PipPipPip
  • 439 messages
  • Gender:Male

Posté 19 juillet 2011 - 08:00

Mon humble avis, qui vaut ce qu'il vaut: non. enfin pas très bien;. je m'explique:

pour piloter un FET, il faut normalement environ 8V. des FET logiques existent, comme celui conseillé par Leon, qui permettent de le piloter directement à partir du µC car il sont saturés à 5V seulement.

autre problème: le combo P/N nécessite de piloter les FET en 12V ( = la tension des moteurs), si mes souvenirs sont bons.

enfin: les FET réagissent au tensions mais ont une capacité parasite de grille (en gros on modélise un transistor entre la masse et la grille); pour charger cette capacité, il est préférable d'utiliser un système envoyant de forts courant (environ 1A), donc très supérieurs au courant du µC. (tu risquerais même peut-être d'abîmer ton µC).

pour toutes ces raisons on utilise la plupart du temps des drivers de mosfet, qui fournissent la bonne tension boostée en courant, qui permet de passer rapidement en bloqué/saturé (le mode intermédiaire, "amplification", est celui qui cause le plus de pertes, donc de chauffe).

Voilà c'était des souvenirs d'une explication d'un de mes profs sur une feuille de brouillon pour un de mes robots, je ne garantie pas l'exactitude des ces infos wink.gif



#8 julkien

julkien

    Pilier du forum

  • Membres
  • PipPipPipPipPip
  • 1 029 messages
  • Gender:Male

Posté 19 juillet 2011 - 09:05

Mon humble avis, qui vaut ce qu'il vaut: non. enfin pas très bien;. je m'explique:

pour piloter un FET, il faut normalement environ 8V. des FET logiques existent, comme celui conseillé par Leon, qui permettent de le piloter directement à partir du µC car il sont saturés à 5V seulement.

autre problème: le combo P/N nécessite de piloter les FET en 12V ( = la tension des moteurs), si mes souvenirs sont bons.

enfin: les FET réagissent au tensions mais ont une capacité parasite de grille (en gros on modélise un transistor entre la masse et la grille); pour charger cette capacité, il est préférable d'utiliser un système envoyant de forts courant (environ 1A), donc très supérieurs au courant du µC. (tu risquerais même peut-être d'abîmer ton µC).

pour toutes ces raisons on utilise la plupart du temps des drivers de mosfet, qui fournissent la bonne tension boostée en courant, qui permet de passer rapidement en bloqué/saturé (le mode intermédiaire, "amplification", est celui qui cause le plus de pertes, donc de chauffe).

Voilà c'était des souvenirs d'une explication d'un de mes profs sur une feuille de brouillon pour un de mes robots, je ne garantie pas l'exactitude des ces infos ;)


Salut
merci de me donner autant de votre temps aussi précieux

@ Alexis: donc si je suis ton raisonnement on ne peux pas utiliser un mofset en mode "amplification" a moin de prevoir un puissant radiateur de la mort qui tue :D
si j'ai bien compris pour utiliser un µc il me faut mettre un transistor entre la gâche (gain) et le µc?
j'ai vue que si on relie la gâche a rien, il y a risque de parasite. celons vous c'est vrai ?

@ maïke: tu as un schéma a nous proposer ?

@ tous merci encore ;)

#9 julkien

julkien

    Pilier du forum

  • Membres
  • PipPipPipPipPip
  • 1 029 messages
  • Gender:Male

Posté 19 juillet 2011 - 09:34

@ Alexis j'ai souvenir de ton vigibot :
comment a tu fais pour alimenté les moteur de perceuse ?

#10 Maïck

Maïck

    Membre passionné

  • Membres
  • PipPipPip
  • 390 messages
  • Gender:Male
  • Location:Suisse

Posté 19 juillet 2011 - 10:13

Oui le relais n'a pas besoin d'avoir un pouvoir de coupure de 100A mais il devra quand même les tenir sans surchauffer !

Si par pont en H tout fait tu entend un IC avec tout intégré, non je ne pense pas que ça existe...

Par contre les contrôleur pour modélisme sont fait avec un pont en H de MOS ! Et on en trouve pour pas trop cher !

@julkien: Non ton montage tel que présenté ne va pas fonctionner, il manque comme dit plus haut la partie qui va driver les MOS ! Mais sur le principe, oui on peut faire varier la vitesse avec un montage en pont en H !

Pour le schéma je n'en ai pas un tout fait pour une telle puissance ! Je me suis toujours contenté de max 10A ! :)

Sur le principe pas grand chose ne change si ce n'est une partie driver un peut costaud ! Le problème pour tester ce type de montage c'est de trouver une charge qui arrive à bouffer les 100A !! :lol:

#11 Hexa Emails

Hexa Emails

    Membre passionné

  • Membres
  • PipPipPip
  • 439 messages
  • Gender:Male

Posté 19 juillet 2011 - 10:29

@ Alexis j'ai souvenir de ton vigibot :
comment a tu fais pour alimenté les moteur de perceuse ?


Je ne l'ai toujours pas fait, mon pont en H home-made ne fonctionne pas (je me suis gourré dans les ref de composants, IRF640 et IRF540 c'est pas la meme chose...) bref je suis bridé en courant ( = en couple), les FET chauffent à mort, le robot n'avance pas... un échec de chez échec quoi ^^

J'ai pris contact avec un mec de letsmakerobots qui fabrique des circuits imprimés pour du CMS, je recevrai une carte de contrôle pour 2 moteurs 50V/30A pour 50$US + fdp (oui oui une carte de contrôle de puissance en CMS!)

En ce moment je n'ai que des projets en standby suite à des échecs :P

j'aurai préféré la faire moi-même, mais là au moins j'aurai un truc optimisé, avec sonde de courant, directement pilotable via l'arduino, je mettrai un ventirad de processeur de PC si ça chauffe trop.

EDIT: je viens de voir tes 1eres questions:

le mode amplification = pilotage en courant. pour certaines applications c'est très utile voire nécessaire, mais bon en effet ça chauffe beaucoup (donc rendement moyen, en embarqué on évite selon moi)

mettre un transistor? en gros c'est ça, on peut meme en mettre 2 pour faire un "push-pull".

et enfin, pour cette histoire de parasites, cela semble très probable, car le nom du transistor traduit est "transistor à effet de champ". Si on ne relie à rien, on a une haute impédance => sujets aux champs magnétiques (ce qui déclenche le transistor)


voilà un type de pont en H "complet": http://www.franciscodias.net/boards/motor-driver-board

le gars l'a testé avec des moteurs de perceuse (150W environ), et ça marchait sans chauffer.

Le shéma proposé par Leon ne vaut pas un pont en H complet, mais il coute beaucoup moins cher (relais de voitures: 0€ environ pour moi. Transistor FET de puissance canal P auprès de mon petit revendeur d'électronique: 8€ pièce. pour 2 moteurs on a vite fait le calcul!).
de plus il est beaucoup plus simple à comprendre pour les débutants.

après si on cherche le rendement, on fait un pont en H à freinage régénératif, contrôlé par des drivers genre IR2011, qui gèrent les temps de montée et de descente pour une transition bloqué/saturé optimale.

Chacun fait son mélange en fonction de son budget et ses connaissances je dirai (et c'est d'ailleurs ce qui me passionne dans la robotique)

#12 ninoub01

ninoub01

    Nouveau membre

  • Membres
  • 1 messages

Posté 25 mai 2013 - 02:28

je suis interessé par ce montage car je suis sur un projet de regulation du courant d'un mcc et pour le montage de puissance j'utilise un mosfet IRF640 et pour le piloter il faudra un driver ,mais je suis bloqué car mon driver est le IR2113 qui pilote de FET et moi j'en ai besoin qu'un seul FET!!! alors si c'est possible de piloter un seul FET par se driver ???



Répondre à ce sujet



  


0 utilisateur(s) li(sen)t ce sujet

0 members, 0 guests, 0 anonymous users