Aller au contenu


Photo
- - - - -

Raspberry Pi et Arduino via Bluetooth


  • Veuillez vous connecter pour répondre
2 réponses à ce sujet

#1 Newbies

Newbies

    Membre passionné

  • Membres
  • PipPipPip
  • 487 messages
  • Gender:Male
  • Location:Paris
  • Interests:Programmation et robotique

Posté 18 juillet 2014 - 12:54

Salut les gars,

Je suis, depuis deux jours, en train d'essayer de faire dialoguer ma Raspberry Pi avec mon Arduino sans succès...

J'ai pourtant TOUT essayé, suivi TOUT les guides, lu TOUTES les documentations sur le sujet mais il m'est toujours impossible d'établir cette maudite connexion...

Je possède donc une raspberry Pi modèle B avec un dongle bluetooth https://www.adafruit.com/products/1327 et une arduino Uno avec un module bluetooth https://www.adafruit.com/product/1588.

J'ai donc commencé par suivre ce guide http://blog.dawnrobotics.co.uk/2013/11/talking-to-a-bluetooth-serial-module-with-a-raspberry-pi/, puis celui la https://learn.adafru...-g-raspberry-pi mais aucun n'a abouti à quelque chose de concluant.

En effet, après avoir "pairer" ma raspberry et mon module en suivant les guides, j'ai donc essayer d'envoyer depuis ma raspberry Pi du texte en bluetooth a l'Arduino ( qui l’interprétera comme une commande ) en utilisant PySerial ( comme dans le premier guide ). Je configure donc mon port série, la "baudrate" toussatoussa et exécute mon code... Et la bim, une erreur :


write failed: [Errno 107] Transport endpoint is not connected

Je me renseigne donc sur internet et tombe sur ce site https://bugzilla.red....cgi?id=1060457 ou ils expliquent que c'est un bug récurant sur les nouvelles versions ( 3.12.6 et 3.12.8 ) du kernel ( dont ma version de Raspbian fait partie ) mais qu'il suffit de rajouter un délais pour laisser le temps à la connexion de s'établir. J'ajoute donc un délais ( de 5 seconde ) à mon code, le re éxecute... Et voila encore l'erreur qui réapparais...

Voila donc mon code de test :
#! /usr/bin/python
 
import serial
import time
 
bluetoothSerial = serial.Serial( "/dev/rfcomm0", baudrate=9600 )
time.sleep(5)
bluetoothSerial.write( "avancer") #Qui doit être reçu par l'Arduino

Voila voila, donc si quelqu'un a une idée ;)

merci :)

#2 Newbies

Newbies

    Membre passionné

  • Membres
  • PipPipPip
  • 487 messages
  • Gender:Male
  • Location:Paris
  • Interests:Programmation et robotique

Posté 18 juillet 2014 - 02:53

Autre chose, je viens d'essayer et de réussir à envoyer des données de mon arduino jusqu'à ma Raspberry via bluetooth ( J'ai utiliser minicom pour les lire sur la raspberry ). Il faut juste qu'on arrive à faire l'inverse maintenant ;)

#3 Newbies

Newbies

    Membre passionné

  • Membres
  • PipPipPip
  • 487 messages
  • Gender:Male
  • Location:Paris
  • Interests:Programmation et robotique

Posté 19 juillet 2014 - 04:08

Problème résolu, c’était en fait un bug récurrent de ma version du kernel ( 3.12 ). J'ai donc "downgradé" ma version du kernel pour 3.10 et tout à marché niquel ;)

Maintenant, espérons que je puisse faire marcher mon écran tactile sur cette vielle version :/




0 utilisateur(s) li(sen)t ce sujet

0 members, 0 guests, 0 anonymous users