Aller au contenu


Photo

Allboot 4 pattes ?


  • Veuillez vous connecter pour répondre
24 réponses à ce sujet

#21 Andreo

Andreo

    Nouveau membre

  • Membres
  • 14 messages
  • Gender:Male
  • Location:Poitou Charente
  • Interests:Mecanique auto, electronique, multimedia

Posté 10 janvier 2021 - 08:17

super, merci j'avais pourtant pas mal chercher.....

 

j'essais et tient au courant

 

merci


Debutant, demande qu'a apprendre !  :thank_you:


#22 Andreo

Andreo

    Nouveau membre

  • Membres
  • 14 messages
  • Gender:Male
  • Location:Poitou Charente
  • Interests:Mecanique auto, electronique, multimedia

Posté 10 janvier 2021 - 08:21

sur le 1er doc j'ai bien compris les branchements, sauf que moi sur mon allbot j'ai deja autre chose dessus.... et le support de batterie par dessus 


Debutant, demande qu'a apprendre !  :thank_you:


#23 Sandro

Sandro

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 794 messages
  • Gender:Male

Posté 10 janvier 2021 - 09:49

Ce n'est pas un un problème : si tu observes bien, tu remarquera que chaque shield (ie chaque "étage") reprends les pins de l'arduino qui est en dessous, au même emplacement : tu peux donc utiliser les "trous" des rangées de trous noir sur le coté du shield des piles comme s'il s'agissait directement des même pins  sur l'Arduino. Peut-être qu'ils ont même pris la peine d'y re-écrire les noms. Si ce n'est pas le cas, il suffit de regarder e nom sur l'arduino qui est en dessous.

 

Attention néanmoins, certains pins sont déjà "pris" (utilisés) par le shield avec les servos.

 

D'après le code, il y aurait de pris :

- le "sounder" : pin 13

- les 8 servos : pins 2, 3, 4, 9, 10, 11, A0, A1

- la communication série (pour la télécommande infrarouge) : pins 0 et 1 (nb : c'est pas très explicite, mais Serial signifie que c'est les pins 0 et 1)

 

Tu peux donc utiliser les pins 7 et 8 comme dans le tutoriel, en te branchant sur le shield des batteries.

 

 

 

Alternativement, si tu regardes la documentation du shield des servos : https://manuals.whad...icle.php?id=562 ,tu verra que les tous les pins de signal de l'Uno (sauf le pin 0) sont relié à un emplacement pour servo. Tu peux donc aussi brancher ton capteur sur les pins "signal" des emplacements servos 7 et 8 (et au passage tu peux récupérer une masse).

ATTENTION : tu ne peux malheureusement pas récupérer le +5V nécessaire depuis ce shield (la sortie "+" est reliée directement aux batteries, donc ça peut monter à 6V, ce qui risque de détruire ton capteur ou l'arduino) : tu devra donc forcément prendre le 5V sur le shield des batteries.



#24 Andreo

Andreo

    Nouveau membre

  • Membres
  • 14 messages
  • Gender:Male
  • Location:Poitou Charente
  • Interests:Mecanique auto, electronique, multimedia

Posté 11 janvier 2021 - 07:08

a priori cela fonctionne, j'ai bien le moniteur qui defile 

 

concernant le moniteur ou afficheur je nai trouv e...


Debutant, demande qu'a apprendre !  :thank_you:


#25 Sandro

Sandro

    Membre chevronné

  • Membres
  • PipPipPipPip
  • 794 messages
  • Gender:Male

Posté 11 janvier 2021 - 07:28

Bonsoir,

les valeurs affichées sont-elles cohérentes?

 

Si oui, la prochaine étape est de définir ce que tu veux faire de la distance (ie quel comportement tu veux adopter (précisément) en fonction de la distance)

 

 

 

Pour ta seconde ligne, j'ai pas compris ce que tu veux dire.






0 utilisateur(s) li(sen)t ce sujet

0 members, 0 guests, 0 anonymous users