Aller au contenu


Vaelan

Inscrit(e) (le) 02 juil. 2015
Déconnecté Dernière activité mars 24 2019 01:56
-----

Messages que j'ai postés

Dans le sujet : Oracid - Mon imprimante 3D Dagoma Discovery 200

13 septembre 2016 - 06:48

Le tube PFTE n a t il pas un defaut ?

Dans le sujet : Oracid - Mon imprimante 3D Dagoma Discovery 200

20 août 2016 - 04:27

Ça fais bien longtemps que je rêve d'une imprimante 3D et ton sujet va peut être me faire sauter le pas en me faisant découvrir la 

Discovery200. Elle a l'air d'avoir tout ce qui me manquait , le prix , la simplicité , un SAV français.... Il me manque juste un avis objectif sur le bruit qu'elle émet. Je suis en appartement (pas de sous sol et encore moins d atelier pour la mettre, elle devra rester dans mon bureau) du coup je me pose la question niveau vibration pour les voisins et niveau bruit dans l appartement (si elle doit tourner plusieurs heure il faudrait quand même qu'elle soit relativement discrète surtout si elle doit tourner la nuit ;)

Dans le sujet : Robot Quadrupède Arduino Uno

19 août 2016 - 01:48

intervertis les servos:

                 Beta avant droite avec Beta arriere droite

et

                 Beta avant gauche avec Beta arriere gauche

 

soit ils sont pas branchés sur la bonne Pin soit il y a une erreur sur la prog de distribution

 

au niveau des batteries Lipo elles sont de 3,7 volt par élément. j'alimente mes servo avec une 2S 1950mAH soit 7,4volt .Temp de recharge de 30 a 45 MN mais bon j'hérite du matériel de modélisme que je possédais déjà et ça demande a être manié avec prudence.

Sinon en NiMh 1,3 volt par élément il me semble moins dangereux a manipuler mais plus contraignant a l'entretien parce qu elle garde une mémoire de charge du coup il faut toujours les décharger complètement avant de les recharger


Dans le sujet : Robot Quadrupède Arduino Uno

18 août 2016 - 07:56

Au vues de ta vidéo il semble qu il y ai un problème avec le "longi".

"alti" et "lateral" à l'air OK  .

Avec Parkinson c'est difficile de voir quel mouvement est inversé.Le code de l'IK tu l'as modifié ou il est comme l'original? 


Dans le sujet : Robot Quadrupède Arduino Uno

17 août 2016 - 10:06

 

 

const float largeur = 8.6;
const float longueur = 11.1;

Tu dois déjà commencer par changer ça par:

const float largeur = 11.1;
const float longueur = 8.6;

 

 

#define avant 1
#define arriere -1
#define droite -1
#define gauche 1

La tu dois bien faire attention que tes servo soit bien monté comme sur mon schéma sinon tu devras adapter

Considère ton robot comme étant un plan Orthonormés dont son centre est le repère (0,0,0) , ce qui veut dire que si avant 1 et arriere -1 alors droite 1 et gauche -1

Fichier joint  quad orthonormees.jpg.png   76,66 Ko   68 téléchargement(s)

La tu vois que j ai des Offset avec des valeurs absolu identique = (3,2)

soit B (3*droite,2*avant) / (3*1,2*1) = (3,2)

       A (3*gauche,2*avant) / (3*(-1),2*1) = (-3,2)

       D (3*gauche,2*arriere) / (3*(-1),2*(-1)) = (-3,-2)

       C (3*droite,2*arriere) / (3*1,2*(-1)) = (3,-2)

 

Et il sont tous à leur place. Il s'agit de placement d'Offset et pas d inversion d'angle(je vais vérifier le prog que je t'ai fais, des fois que je me soit trompé)