Aller au contenu


Photo
- - - - -

Conseils pour alimentation


  • Veuillez vous connecter pour répondre
8 réponses à ce sujet

#1 Sheraf

Sheraf

    Nouveau membre

  • Membres
  • 26 messages

Posté 04 octobre 2022 - 02:42

Bien le bonjour.

 

 

Je viens vous demander un peu d'aide (toujours pour mon projet de theatre robotique)

 

 

Je vais essayer de vous décrire un peu mon systeme avant de poser mes questions.

 

J'utilise cette carte pour controller mes moteurs. C'est pas de l'arduino. Pour l'instant je suis completement ignare dans ce domaine, je programme tout en DMX (c'est quelquechose que je changerai probablement un jour, mais pas tout de suite)

 

Pour l'instant, au niveau de l'alimentation pour mes robots, j'utilise une alimentation de PC qui me permet de chopper du 12v avec les fils jaunes, et 5v avec les fils rouges.

Le tuto du site qui vend la carte interface-z conseillait ça, et ça a toujours plus ou moins bien marché.

 

Mais je commence à me demander si ma façon d'alimenter mes moteurs n'est pas la source de certains problemes:

-de façon aléatoire, la tête de ce robot tombe sur le coté et ne se releve plus

-un ou deux bras de ce robot ne bougent plus alors qu'ils devraient tous bouger. (Souvent un bras reste coincé. Je dois le pousser pour l'approcher de la position dans laquelle il est censé être. Des que le bras est proche de la bonne position ça remarche).

 

 

Sur ces cartes, je branche parfois différents type de moteurs en même temps.

 

Par exemple, sur presque toutes les cartes, j'ai ceux là, et ceux là branché sur la même carte.

 

 

Est ce que l'alimentation en 5v est un probleme ?

Les petits SG bleu fonctionnent entre 4,8 à 6 Vcc, donc 5v ça me parait bien. Mais les longrunner sont entre  6 et 7,4 V.

J'aurais bien envie de les remplacer par ce modele là, mais c'est le même soucis.

 

Est ce que ça marchera mieux avec une autre alimentation qui fournit du 6v ?

 

 

Et là du coup, j'ai une vrai question existentielle: 

 

Quelle genre d'alimentation me conseillez vous ?

 

 

J'ai regardé un peu les différents convertisseur sur le site. C'est ce genre de truc qu'il me faut ?

 

 

J'ai un peu peur d'être limite niveau ampérage parfois. Sur Bobodoc par exemple, j'ai 2 cartes interface-Z, avec 16 servomoteurs branché (5 hitec 422, et 11 longrunner). Le problème c'est que je ne sais pas vraiment quel ampérage est necessaire pour chaque servo.

 

Le robot est démontable pour être transporté entre les représentations. Donc tout est à l'interieur sauf l'alimentation. J'arrive donc directement depuis l'alimentation PC en 5 et 12V, que je reparti à coup de domino dans toutes les cartes (pour les leds et les servomoteurs).

 

Dans l'idéal, j'aimerais éviter de rajouter des maillons faibles dans mes robots. Les potentielles pannes sont inacceptable, vu qu'on est au théâtre, donc brancher des convertisseurs devant chaque carte me parait bancale.

 

J'aime assez le principe de ma grosse alimentation PC qui gère le 5v et le 12v, et que je branche un peu partout sur mon décor.

Est ce genre de produit dont j'ai besoin ? Ca ne fait que 10 ampère par contre. Peut être dois-je en prendre plusieurs qui alimentent chacune certaines parties du décor (et donc des robots) ?

 

 

 

Voilà désolé pour le pavé. j'espère que vous saurez m'aider.

 



#2 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 9 472 messages
  • Gender:Male
  • Location:Anglet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 04 octobre 2022 - 07:50

Alors des réponses en plusieurs point : 

Tout d'abord, avoir une alimentation de labo comme celle que tu as mentionné c'est un très bon outil pour mesurer la consommation de tes servomoteurs et vérifier comment ils se comportent en fonction de la tension d'alimentation. Mais je vois ça plutôt comme un outil et pas comme le convertisseur que tu dois utiliser partout. 

Après pour un " outil " au vu de ton besoin tu peux peut être trouver ça un peu cher... En produit qui peuvent avoir la même application j'ai : 
https://www.robot-ma...ichage-302.html 
et 
https://www.robot-ma...zk-4kx-581.html 

Je te recommande vivement de faire des tests en alimentant tes servo avec une alimentation comme ça qui t'affiche le courant consommé en temps réel pour que tu ais une vrai réponse de combien consomment les moteurs de tes robots, c'est important pour dimensionner correctement tes convertisseur.


Ensuite si tu as plusieurs servomoteurs qui ont différents besoin d'alimentation tu peux tout simple tirer différentes lignes d'alimentation pour les différents besoins. 
Et sur le principe c'est pas une mauvaise idée car ça va dans le sens de " diviser pour mieux régner " ... 

Avoir une alimentation pour tout alimenter ça peut paraître bien comme ça mais quand on arrive à des gros besoin de courant c'est pas forcément l'idéal, avoir plusieurs alimentation c'est mieux rien que pour la puissance dissipée...

Ensuite dit toi que dimensionner correctement l'alimentation c'est bien mais il faut aussi correctement dimensionner le diamètre de tes câbles surtout si tes câbles sont long ... Si tu as une très grosse alim et des petits câbles tu auras aussi un problème ..

Une fois qu'on saura grosso modo combien consomment tes servo en charge on pourra te guider au mieux pour tes convertisseurs et tes câbles.


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !
En attendant qu'une bibliothèque de fichiers 3D soit mise en place n'hésitez pas à demander si vous avez besoin du fichier 3D d'un des produits de la boutique... On l'a peut être ! 

 

Les réalisations de Mike118  

 

 

 


#3 Oracid

Oracid

    Pilier du forum

  • Modérateur
  • PipPipPipPipPip
  • 6 143 messages
  • Gender:Male

Posté 04 octobre 2022 - 08:07

Peux-tu nous montrer ton alimentation de PC ou nous en donner les caractéristiques ?

 

Ton installation, c'est un peu comme un orchestre (rock) avec des guitares, des amplis, des retours, des micros etc.

Aujourd'hui, dans ce type d'installation, chaque élément, même un micro (pas tous) a son alimentation et est directement connecté au 220V, ou une petite batterie pour les micros.

Mais je pense que tu connais tout ça très bien.



#4 Sheraf

Sheraf

    Nouveau membre

  • Membres
  • 26 messages

Posté 04 octobre 2022 - 09:20

Les caracteristiques de l'alim je les ai pas là. Je peux essayer de regarder demain mais elle est un peu "enterré" dans un chassis que j'ai fabriqué (bien ventilé, mais difficilement accessible).

 

Je suis quasiment sûr que ça suffit largement en puissance (750w).

J'ai un ptit doute mais je crois que c'est celle là:

https://www.amazon.f...e?ie=UTF8&psc=1

 

 

De toute façon dans mon installation, je peux debrancher tous les robots sauf un pour tester. Ca ne change rien au niveau de bobodoc par exemple. Meme si je le branche tout seul, il galère dans certain mouvement (souvent les mêmes, donc je soupçonne que ça se passe quand tous les moteurs s'activent un peu trop fort en même temps).

Donc je pense pas que ça manque d'ampers.

 

J'y connais rien en electricité, mais entre 5v et 6v, ça doit changer pas mal. Ca fait 20% de difference !

Si les carateristiques des moteurs disent "entre 6v et 7.4v", et  que je leur donne que 5v, ça doit être ça la source du probleme, non ?

 

D'ailleurs, j'avais toujours trouvé étrange que  le robot MP3 ne déconne pas du tout, alors que la même carte interface-z alimente à la fois des petits SG90 en même temps que des HITEC HS-755HB. Mais en regardant les caracteristiques des moteurs, c'est les mêmes (4.8v-6v).

 

Mais bon je suis sûr de rien. Encore une fois, j'y connais rien.

 

 

 

Alors des réponses en plusieurs point : 

Tout d'abord, avoir une alimentation de labo comme celle que tu as mentionné c'est un très bon outil pour mesurer la consommation de tes servomoteurs et vérifier comment ils se comportent en fonction de la tension d'alimentation. Mais je vois ça plutôt comme un outil et pas comme le convertisseur que tu dois utiliser partout. 

Après pour un " outil " au vu de ton besoin tu peux peut être trouver ça un peu cher... En produit qui peuvent avoir la même application j'ai : 
https://www.robot-ma...ichage-302.html 
et 
https://www.robot-ma...zk-4kx-581.html

Je te recommande vivement de faire des tests en alimentant tes servo avec une alimentation comme ça qui t'affiche le courant consommé en temps réel pour que tu ais une vrai réponse de combien consomment les moteurs de tes robots, c'est important pour dimensionner correctement tes convertisseur.


Ensuite si tu as plusieurs servomoteurs qui ont différents besoin d'alimentation tu peux tout simple tirer différentes lignes d'alimentation pour les différents besoins. 
Et sur le principe c'est pas une mauvaise idée car ça va dans le sens de " diviser pour mieux régner " ... 

Avoir une alimentation pour tout alimenter ça peut paraître bien comme ça mais quand on arrive à des gros besoin de courant c'est pas forcément l'idéal, avoir plusieurs alimentation c'est mieux rien que pour la puissance dissipée...

Ensuite dit toi que dimensionner correctement l'alimentation c'est bien mais il faut aussi correctement dimensionner le diamètre de tes câbles surtout si tes câbles sont long ... Si tu as une très grosse alim et des petits câbles tu auras aussi un problème ..

Une fois qu'on saura grosso modo combien consomment tes servo en charge on pourra te guider au mieux pour tes convertisseurs et tes câbles.

 

 

 

 

Je vais essayer de répondre à tout (mais pas dans l'ordre).

 

J'ai des cables énormes :) Souvent trop gros même, mais je pense pas que ce soit un problème. Surtout que Glouglou et Bobodoc ont une longueur de cable largement inferieur à d'autres qui n'ont pas de probleme (mais ils n'ont pas ces moteurs 6v)

 

J'avais repéré les convertisseurs que tu as linké, mais j'avais un peu peur au niveau de l'amperage. 5A, ça me parait trop peu pour bobodoc. L'une de ses cartes a 8 longrunner branché dessus. Les caracteristiques semblent les mêmes que le Feetech SCS15 où y a marqué "Consommation moteur bloqué: 1,5 A"

 

 

J'ai bien peur que "diviser" pour mieux régner ne puisse pas être une option dans plusieurs cas.

Pour les cartes servo-DMX de interface-Z, j'ai deux entrées de courant. Une 12v qui sert plus ou moins à rien, et une pour le 5v (ou 6 ou 7 etc... selon les moteurs) pour les servo. Si je branche des Feetech SCS15 et des SG90 sur cette même carte, je suis obligé de choisir une tension identique pour tout le monde.

 

Après, je pourrais aussi avoir plusieurs cartes selon les moteurs que j'y branche, mais ça fait beaucoup de dépenses inutiles (ça revient vite cher ces cartes).

Le robot Glouglou c'est le pire robot dans ce cas là. Il a besoin de 2 longrunners (pareil que le feetech) pour son cou. Ces moteurs sont hyper pratiques car ils ont le mécanisme integré au systeme. En cas de panne ou de casse, je peux remplacer ça en moins de 5min (ça nous est déjà arrivé).

Mais sur sa tête, j'ai mis deux tout petit SG90 pour faire les sourcils. Je ne sais pas utiliser autre chose pour son cou, et je ne peux pas mettre des trucs gros, lourd et moche sur sa tête juste pour ça. 

 

Là d'instinct je me dis que si j'avais pile poil 6v de tension avec un ampérage enorme, ça devrait fonctionner mieux.

 

 

Du coup derniere question. L'alimentation de labo là, tu dis que c'est un bon outil, mais pas forcement utile pour alimenter.

Tu trouves ça bête parce que c'est overkill ? Ou est ce que c'est carrement une mauvaise idée ?

 

Je compte pas en acheter 15. Là en regardant vite fait mon installation, avec 2, je suis laaaaaarge.

Je garde mon alimentation de PC pour alimenter tout sauf Bobodoc et Glouglou (les deux seuls qui ont des moteurs 6-7.4v). Eux je les branche sur ce truc de labo qui me donne du 6v précisément.

 

J'essaye d'abord avec un seul pour les deux, et si 10A ça suffit pas, j'en achete un deuxième.

 

C'est con ?

 

L'avantage énorme que j'y vois, c'est que vu ma méthode de branchement, si j'ai une alim qui pète en plein spectacle, je peux toujours rebrancher mon ancienne prise qui va à l'alim PC qui balance du 5v. Ca déconnera toujours un peu, mais show must go on.

 

Si j'ai un ptit convertisseur qui lache à l'interieur du robot, je suis foutu.



#5 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 9 472 messages
  • Gender:Male
  • Location:Anglet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 05 octobre 2022 - 05:09

Je comprend ton point de vu... Vu de cette façon oui tu peux utiliser directement un alimentation comme ça. 

( Sinon si tu as des gros câbles tu devrais pas avoir de soucis avec le dimensionnement des câbles au détail près que plus gros, c'est plus cher et plus lourd, point de vu courant plus les câbles seront gros et mieux ça sera ;) )

Enfin dernier point, les SCS15 ne sont pas des servomoteurs classique comme tu as l'habitude d'utiliser, ce sont des servomoteurs intelligents, ça ne se pilote pas de la même manière du coup tu ne peux pas les utiliser avec ta carte servo DMX ...


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !
En attendant qu'une bibliothèque de fichiers 3D soit mise en place n'hésitez pas à demander si vous avez besoin du fichier 3D d'un des produits de la boutique... On l'a peut être ! 

 

Les réalisations de Mike118  

 

 

 


#6 Sheraf

Sheraf

    Nouveau membre

  • Membres
  • 26 messages

Posté 05 octobre 2022 - 03:18

!!!

Oula merci tu fais bien de me le dire.

 

J'allais en acheter quelques uns pour remplacer ces LongRunner que j'ai trouvé il y a longtemps sur amazon mais qui ne sont pas toujours disponible. Ca va, ça vient, ça change de vendeur, de prix...

 

Je voulais surtout les changer car je suis tombé sur un probleme chelou avec eux recemment. J'en avais racheté 5 ou 6 en rab pour avoir du spare.

 

Il n'y a pas longtemps, j'ai remplacé le moteur qui permet à Glouglou de faire oui de la tête.

J'ai branché le moteur juste pour le mettre en position horizontale, puis j'ai tout simplement changé le moteur. Et bizarrement, le nouveau avait une amplitude d'angle de rotation inferieur à l'ancien. J'avais rien changé sur la carte, rien dans la programmation.

Anciennement, le moteur permettait (quand il était à fond) de mettre la tête complètement verticale vers le haut (ce qui était sa position quand le robot est éteint dans la mise en scène).

Avec le nouveau moteur, il regarde juste très très haut. Mais il est pas à la verticale.

 

C'est très bizarre, mais du coup je me dis que cette marque de moteur n'est pas fiable.

 

 

J'aimais bien ce type de moteur avec les charnières intégrées. Faudrait peut être que je trouve une autre façon de faire.



#7 Mike118

Mike118

    Staff Robot Maker

  • Administrateur
  • PipPipPipPipPip
  • 9 472 messages
  • Gender:Male
  • Location:Anglet
  • Interests:Robotique, Entrepreneuriat, Innovation, Programmation, Résolution de problème, Recherche de solutions, Mécanique, Electronique, Créer, Concevoir

Posté 05 octobre 2022 - 05:39

Je peux quand même te fournir des moteurs avec charnière intégré et qui sont fiable et qui sont des servomoteurs standard compatible avec ta carte ... Mais ils sont pas encore sur la boutique, je reviens bientôt avec un produit pour toi ;) ( tu en voudrais combien des moteurs en théorie ? )


Si mon commentaire vous a plus laissez nous un avis  !  :thank_you:

Nouveau sur Robot Maker ? 

Jetez un oeil aux blogs, aux tutoriels, aux ouvrages, au robotscope  aux articles,  à la boutique  et aux différents services disponible !
En attendant qu'une bibliothèque de fichiers 3D soit mise en place n'hésitez pas à demander si vous avez besoin du fichier 3D d'un des produits de la boutique... On l'a peut être ! 

 

Les réalisations de Mike118  

 

 

 


#8 Sheraf

Sheraf

    Nouveau membre

  • Membres
  • 26 messages

Posté 05 octobre 2022 - 07:22

Difficile à dire pour l'instant. Pour l'instant je t'en prendrais bien 3 pour tester.

 

Après on doit faire un point sur le budget avec les autres producteurs.

 

 

J'ai pour projet de refaire tous les robots en version améliorée, (et en double pour palier à une panne soudaine), mais on va devoir surement attendre quelques mois (voir l'année prochaine) que les caisses se remplissent un peu.

 

Si je refais bobodoc et glouglou avec ces nouveaux moteurs, il m'en faudra 26 au total (arrondis à 30 pour avoir quelques moteurs d'avance si un truc casse). Mais c'est pas pour toute suite :)

 

Et ça peut changer, peut être que je reverrai un peu le design de bobodoc pour mettre moins de moteur. C'est un peu abusé là.



#9 chicextraneous

chicextraneous

    Nouveau membre

  • Membres
  • 1 messages

Posté 24 novembre 2022 - 05:24

Well hello.

 

 

I come to ask you for a little help (still for my robotic theater project )

 

 

I will try to describe my system a bit before asking my questions.

 

I use this board to control my motors . It's not Arduino. For the moment I am completely ignorant in this field, I program everything in DMX (it's something that I will probably change one day, but not right away)

 

For the moment, at the level of the food for my robots, I use a PC power supply which allows me to chopper 12v with the yellow wires, and 5v with the red wires.

The tutorial on the site that sells the interface-z card recommended that, and it always worked more or less well.

 

But I'm starting to wonder if my way of powering my motors is not the source of some problems:

- randomly, the head of this robot falls on the side and does not get up again

-one or two arms of this robot no longer move when they should all move. (Often an arm gets stuck. I have to push it to bring it closer to the position it's supposed to be in. As soon as the arm is close to the right position it works again).

 

 

On these cards, I sometimes connect different types of motors at the same time.

 

For example, on almost every card, I have these , and these plugged into the same card.

 

 

Is the 5v supply a problem?

The small blue SGs operate between  4.8 to 6 Vdc, so 5v seems fine to me. But the longrunners are between   6 and 7.4 V.

I would really like to replace them with this model tunnel rush, but it's the same problem.

 

Will it work better with another power supply that provides 6v?

 

 

And suddenly, I have a real existential question: 

 

What kind of diet do you recommend?

 

 

I looked a little at the different converters on the site. Is this the kind of thing I need?

 

 

I'm a little afraid of being at the amperage level limit sometimes. On Bobodoc for example, I have 2 interface-Z cards, with 16 servomotors connected (5 hitec 422, and 11 longrunner). The problem is that I don't really know what amperage is needed for each servo.

 

The robot can be dismantled to be transported between performances. So everything is inside except the power supply. I therefore arrive directly from the PC power supply in 5 and 12V, which I leave with a domino in all the cards (for the LEDs and the servomotors).

 

Ideally, I would like to avoid adding weak links in my robots. The potential breakdowns are unacceptable, since we are at the theater, so connecting converters in front of each card seems to me wobbly.

 

I quite like the principle of my big PC power supply which manages 5v and 12v, and which I plug in everywhere on my decor.

Is this kind of product what I need?  It's only 10 amps though. Maybe I should take several that each supply certain parts of the decor (and therefore the robots)?

 

 

 

So sorry for the mess. I hope you can help me.

 

 

:bad:  :bad:






0 utilisateur(s) li(sen)t ce sujet

0 members, 0 guests, 0 anonymous users